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11::  DDeessccrriippttiioonn  aanndd  SSppeecciiffiiccaattiioonnss  
About the User Guide 

This guide details the configuration and management of devices using the 
DeviceInstaller.  It is intended for Network Administrators responsible for the 
configuration and maintenance of devices on the network. 

DeviceInstaller Overview 

The DeviceInstaller is an all-in-one utility for setting up various Lantronix devices on a 
network.  It auto-detects any devices on the network and allows configuration of 
network and serial port settings.  As a management tool, the DeviceInstaller allows 
for device monitoring and status verification. 

System Requirements 

 Windows XP, Windows 2000, Windows NT4.0 (with service pack 6.0a or 
later), or Windows 98 

 Internet Explorer 5.01 or later 
 30MB hard drive space 
 64MB RAM 
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22::  IInnssttaalllliinngg  tthhee  DDeevviicceeIInnssttaalllleerr  
Before installing the DeviceInstaller, ensure system requirements are met.  Refer to 
System Requirements on page 1-1 for details.   

Note: The installation adds Microsoft’s .NET software onto the system.  

To install the DeviceInstaller: 

1. Insert the DeviceInstaller CD into the CD ROM drive. 

2. If the CD does not launch automatically:  

a. Click the Start button on the Task Bar and select Run.  

b. Enter the CD drive letter, colon, backslash, Launch.exe (e.g., 
D:\Launch.exe).  

3. The DeviceInstaller Setup Wizard opens to guide the installation process.  Click 
Next to open the Select Installation Folder window. 

4. The Select Installation Folder window prompts for a destination folder for the 
installation.  Click Browse to change the default destination.  Click Next to open 
the Confirm Installation window. 

5. From the Confirm Installation window, click Next to begin the installation.  The 
Installation Complete window displays when the installation is finished. 

6. Click Close to exit.   
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33::  AAddddiinngg  aa  DDeevviiccee  ttoo  tthhee  LLiisstt  
The DeviceInstaller displays a list of the devices on the network.  When the 
DeviceInstaller initially starts, the device list is empty.  Devices may be added by 
performing a search for the devices on the network or by adding them manually. 

Note:  Optionally, if more than one network adapter exists on the PC, select an 
alternative adapter.  All network communication uses the selected adapter.  Refer to 
Choosing the Network Adapter for Communication on page 7-3 for more information. 

This chapter includes the following topics: 

Topic Page 
Search for all Devices on the Network 3-1 

Manually Add a Device to the Device List 3-1 

Search for all Devices on the Network 

The Search tool finds all devices within the local area network and adds them to the 
device list. 

1. From the main toolbar, click Search . It may take several seconds for the list 
of devices to display in the device list. 

 

Manually Add a Device to the Device List 

As an alternative to using the Search tool to add devices to the device list, add 
individual devices manually to the list.  This includes devices for use on the local 
subnet. 

1. From the Device menu, select Add Device.  The Add Device window displays. 



Adding a Device to the List 
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2. Enter the IP address for the device.  Click OK for the DeviceInstaller to search for 
the device. 

3. Upon connection with the device, DeviceInstaller adds it to the device list.  A pop-
up message appears if the device is not found. 
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44::  CCoonnffiigguurriinngg  IIPP  AAddddrreesssseess  
The DeviceInstaller assigns IP addresses to devices on the network.  IP addresses 
are assigned either manually or automatically by the system. 

This chapter includes the following topics: 

Topic Page 
Setting the IP Address Manually 4-1 

Setting the IP Address Automatically 4-2 

Setting the IP Address Manually 

1. From the device list, click on the device to highlight it. 

 

2. From the main toolbar, click Assign IP  to open the Assign IP Address 
window. 

Note:   The Device Identification window prompts for the device’s hardware 
address if a device was not selected in the previous step.  Enter the 
hardware address from the product label and click Next. 

3. From the Assignment Method page, select Assign a specific IP address. Click 
Next to open the IP Settings page. 
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4. In the IP Settings page, enter the device’s IP address, subnet mask, and default 
gateway in the appropriate fields. Click Next to open the Assignment page. 

 

5. Click the Assign button to add the IP address to the device.   

6. The Assign IP Address window indicates when the assignment is complete.  
Click Finish to exit. 

Setting the IP Address Automatically 

1. From the device list, click the device name to highlight it. 

2. From the main toolbar, click Assign IP  to open the Assign IP Address 
window. 

Note:   The Device Identification window prompts for the device’s hardware 
address if a device was not selected in the previous step.  Enter the 
hardware address from the product label and click Next. 

3. Select Obtain an IP address automatically. Click Next to open the IP 
Discovery Settings page. 
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4. Select the network protocol for searching and obtaining the IP address. Click 
Next to open the Assignment page. 

Note:  The device may not support every protocol listed.  Unsupported 
protocols are disabled in the list of protocols. 

5. Click the Assign button to add the IP address to the device.   

6. The Assign IP Address window indicates when the assignment is complete.  
Click Finish to exit.
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55::  CCoonnffiigguurriinngg  DDeevviiccee  SSeettttiinnggss  
Each device in the DeviceInstaller’s list has viewable or modifiable settings.  
Depending on the device type, these settings may be viewed for each individual unit, 
as well as for groups of devices. 

Note:  When highlighting multiple devices for configuration, not all fields are 
available in the Configure Device window. 

This chapter includes the following topics: 

Topic Page 
Documenting Details for a Device 5-1 

Configuring Ports 5-2 

Configuring Advanced Settings 5-4 

Documenting Details for a Device 

Add details for a given device using the DeviceInstaller.  Configurable details include 
the device name, group, and additional comments.  These fields display in the device 
list and are used when sorting the list.  A device’s details can be printed and saved to 
files. 

Note:  The device’s name, group, and comments are not stored on the 
device.  

To enter details for a device in the device list: 

1. Click a particular device in the list and press Configure. The Configure Device 
window opens. 

 

 



Configuring Device Settings 

5-2  DeviceInstaller™ User Guide 

 

2. Click the Documentation tab.  Enter details in the Name, Group, and 
Comments fields.  All parameters are optional.   

3. To save and exit, click OK. 

Configuring Ports 

Note: UDS, Micro, Xpress, and XPort devices are supported.  Configure 
other devices via their web page (see Accessing a Device via the Web 
Interface on page 7-1) or by Telnet (see Accessing a Device via Telnet on 
page 7-1). 

To configure the device’s ports: 

1. From the device list, select a particular device (or highlight several devices by 
pressing Ctrl while clicking on the device, if permitted by the device type) and 
press Configure.  The Configure Device window opens. 

 

2. Click the Ports tab. 

Note: The Ports tab is not available on all products. 
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Select the ports to configure and press Edit Settings to open the Port Settings 
window. 

 

3. The Port Settings window displays general serial port settings.  Select the 
Advanced tab to configure advanced serial port settings.  

 

If configuring multiple ports, a blank field indicates the current value varies among 
ports. 
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Note:  For specific information on configuring parameters, refer to the device 
model’s product documentation.  

4. Click Close to exit. 

Configuring Advanced Settings 

Note: UDS, Micro, Xpress, and XPort devices are supported.  Configure 
other devices’ advanced settings via their web page (see Accessing a Device 
via the Web Interface on page 7-1) or by Telnet (see Accessing a Device via 
Telnet on page 7-1). 

To configure specific advanced features of a particular device: 

1. Click a particular device (or highlight several devices by pressing Ctrl while 
clicking on the device, if the device type permits it) and press Configure. The 
Configure Device window opens. 

 

 

2. Click the Advanced tab.  The Advanced window displays configurable advanced 
fields for the device. 
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Note: for specific information on configuring parameters, refer to the device 
model’s product documentation.  

3. Click OK to save changes and exit. 
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66::  UUppggrraaddiinngg  FFiirrmmwwaarree  
Firmware on a device can be upgraded using the DeviceInstaller.  There are two 
ways to upgrade the firmware: by using an existing Lantronix Installer file or by 
specifying individual firmware files. 

Note: A Lantronix Installer file (.lxi) is created when installation settings are 
saved.  The individual files are stored in the .lxi file for later use. 

This chapter includes the following topics: 

Topic Page 
Upgrade Using an Existing Installation File 6-1 

Upgrade Using Individual Firmware Files 6-2 

Upgrade Using an Existing Installation File 

To upgrade the firmware on a device using a Lantronix Installer (lxi) file: 

1. Click the device in the device list to highlight it. 

 

2. Select Upgrade from the Device menu.  The Device Upgrade Wizard window 
displays. 



Upgrading Firmware 
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3. To upgrade using a current installation file, select the Use a specific installation 
file radio button. 

4. Click Browse to open the Select Installation File window.  Locate the correct 
Lantronix Installer file (.lxi) and click Open to set the file location path in the 
Device Upgrade Wizard window. 

5. Click Next to proceed with the upgrade.  The Device Upgrade Wizard window 
displays the status and result of the upgrade. 

6. When the upgrade is complete, select Close to exit. 

Upgrade Using Individual Firmware Files 

The following table details devices that may upgrade using individual files and the file 
types required.  A .rom file is the device’s firmware file.  A .fwx is a firmware 
extension file.  A .cob file contains the data for the device’s web pages. 

Device Upgrade Files 
XPort xxxx.rom, xxxx.cob 
WiPort xxxx.rom, xxxx.fwx, 

xxxx.cob 
UDS xxxx.rom, xxxx.cob 
CoBox-FL xxxx.rom, xxxx.cob 
SDS xxxx.rom, xxxx.cob 
XPress xxxx.rom, xxxx.cob 

To create a custom installation: 

1. Select Upgrade from the Device menu to open the Device Upgrade Wizard 
window. 

2. Select the Create a custom installation by specifying individual files.  Click 
Next. 
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3. Click Browse under the Firmware (ROM) File field to open the Select ROM 
Firmware File window.  Locate the appropriate file and click Open to set the file 
location path in the Device Upgrade Wizard window. 

Note: For WiPort devices, repeat the above step for setting the file 
location of the appropriate Firmware Extension File (.fmx) by clicking 
Browse under the Firmware Extension (FWX) File field. 

To use the existing ROM and FWX files, leave these fields blank. 

4. Click Next.  The Device Upgrade Wizard prompts for the type of files to add. 
Select one of the following: 

 Install files individually to add files in their raw form. 
 Install files contained in COB partitions to add files in the form of COB 

partitions. 
 Do not copy or replace any files to continue with the current files on the 

system. 
Click Next. 

5. If Install files individually was selected in the previous page, the Step 4 of 7 
window is displayed.  

 

From this window: 

a) Click Add Files and choose the files on the system to add files to the 
installation. 
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b) Remove a file scheduled for installation by highlighting the filename and 
clicking Remove. 

c) Select Change Path to change the file location on the device. 

Click Next. 

6. If Install files contained in COB partitions was previously selected, the Step 4 
of 6 window is displayed. 

 

From this window: 

a) To set a file partition, highlight the partition in the displayed list and click Set 
Partition.  The Select COB Archive File window displays; locate the 
appropriate .cob file and click Open.  The files in a partition are displayed in 
the list. 

b) To erase a file partition, select the partition and click Erase.  

c) To leave a file partition intact, select the partition and click No Change.   

When finished, click Next. 

7. As an optional step, save the installation as a Lantronix installation file (.lxi).  
From the Step 5 of 6 window, click Save Installation.  Click Next to continue the 
installation, or Cancel to exit without the actual device upgrade. 

8. The Device Upgrade Wizard window displays the status and result of the 
upgrade.  When the upgrade is complete, select Close to exit. 
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77::  MMaannaaggiinngg  TTaasskkss  
Several device management steps may be performed through the DeviceInstaller.  
These include accessing the device via Telnet or the device’s web interface, saving 
and printing the device list, verifying diagnostics, choosing network adapters, and 
recovering firmware. 

This chapter includes the following topics: 

Topic Page 
Accessing a Device via Telnet 7-1 

Accessing a Device via the Web Interface 7-1 

Saving the Device List 7-2 

Opening the Device List 7-2 

Printing the Device List 7-2 

Checking Device Diagnostics 7-3 

Choosing the Network Adapter for 
Communication 7-3 

Recovering Firmware 7-4 

Accessing a Device via Telnet 

To connect to a device using Telnet: 

1. From the DeviceInstaller list of devices, highlight the appropriate device by 
clicking on it. 

2. From the main toolbar, click Telnet .  A new Telnet window displays. 

 

3. The Port field displays the device’s default port number.  To change this value, 
enter the port number used for accessing the device’s configuration interface.  

4. Click OK to display the Window’s Telnet screen.  Follow the instructions 
displayed in the Telnet window.  For detailed information, refer to the product 
documentation for the device. 

Accessing a Device via the Web Interface 

Use DeviceInstaller if a device has a web page: 
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1. From the list of devices, highlight the appropriate device by clicking on it. 

2. From the main toolbar, click the Web  button.  The device’s web page opens 
in a new browser window. 

Saving the Device List 

The list of devices may be saved as a text file and restored for later use.  The 
following information is stored: 

 Device Name 
 Group 
 Comments 
 IP Address for the device 

Note:  The configuration of the devices in the list is not stored when saving 
the device list. 

To save the list of devices: 

1. From the File menu, select Save As.  The Save As screen displays in a new 
window. 

2. Locate the directory in which the device list text file will be saved. 

3. The default name of the file is Devices1.  To rename the file, clear the File name 
field and enter another filename. 

4. Click Save. 

Opening the Device List 

To open a previously stored list of devices: 

1. From the File menu, click Open.  The Open window displays. 

2. Find the location of the stored device file list (in text format).  Highlight the 
filename and press Open.  The list of stored devices displays in the 
DeviceInstaller window. 

3. To close the list, select New from the File menu. 

Printing the Device List 

To print the current list of devices displayed: 

1. As an optional step, the list of devices may be previewed before printing.  From 
the File menu, choose Print Preview to display the Print preview window. 
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  Click Close to exit. 

2. From the File menu, click Print to print the list of devices. 

Checking Device Diagnostics 

To determine whether a device is online and the network is functional, use the 
DeviceInstaller Ping option.  This option ensures the device is operating and also 
determines the speed of a response from the device. 

1. From the Tools menu, click Ping.  The Ping Device window displays. 

2. In the IP Address box, enter the IP address of the device.   

3. Click Ping.  After several moments, the Status area displays the ping results. 

4. To ping another device, select Clear Status to clear the Status area before 
entering another IP address. 

5. Click Close to exit. 

Choosing the Network Adapter for Communication 

By default, the primary adapter used by Windows is the network adapter used for 
communication with devices on the network.  To select a different adapter: 

1. From the Tools menu, click Options.  The Options window opens, displaying the 
list of available adapters. 
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2. Select the adapter by clicking its checkbox.  Click Apply. 

3. Click OK to exit. 

Recovering Firmware 

In the event of a failure, the Recover option allows for firmware installation through 
the serial port instead of the network.   

Note: the Recover option only supports XPort and Micro100.  Ensure the 
firmware is the correct type before installing over the serial port. 

To install firmware over the serial port: 

1. From the Tools menu, select Advanced.  Choose Recover Firmware.  The 
Serial Port Firmware Upgrade displays in a new window. 

 

2. Power off the device.  Connect a serial cable from the PC running the 
DeviceInstaller to the primary serial port on the device.   

3. From the Serial Port Firmware Upgrade window, choose the PC port from the 
Port on PC drop-down menu. 

4. Choose a device type from the Device Model pull-down menu. 

5. Locate the firmware file on the PC by clicking Browse.  From the Files of type 
pull-down menu, select the file type of the firmware file.  Available file types are 
ROM (.rom), serial program binary (.spb), or serial download binary (.sdb).   
Highlight the filename and click Open.  The file’s path is displayed in the 
Firmware File field. 

Note:  Serial download binary (.sdb) files download the file temporarily into 
RAM.  The previous firmware is restored upon reset. 



Managing Tasks 

DeviceInstaller™ User Guide   7-5 

6. Click OK.  The status bar in the DeviceInstaller window indicates the progress of 
the firmware upgrade. A confirmation box appears when the upgrade is 
complete. 

Note: The status bar may prompt to reset the device. If this occurs, reset or 
toggle the power on the unit to continue with the firmware upgrade. 
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AA::  CCoommpplliiaannccee  aanndd  WWaarrrraannttyy  IInnffoorrmmaattiioonn  
LIMITED WARRANTY 
 
Lantronix warrants that the DeviceInstaller (“Software”),will perform substantially in 
accordance with its accompanying specification documentation for a period of ninety (90) 
days from the date of receipt. AS TO ANY DEFECTS DISCOVERED AFTER THE NINETY 
(90) DAY PERIOD, THERE IS NO WARRANTY OR CONDITION OF ANY KIND. Any 
supplements or updates to the Software, including without limitation, any (if any) service 
packs or hot fixes provided to you after the expiration of the ninety day Limited Warranty 
period are not covered by any warranty or condition, express, implied or statutory. 
LIMITATION ON REMEDIES. If the Software does not meet this Limited Warranty, your 
exclusive remedy shall be, at Lantronix’s option (a) return of the price paid (if any) for the 
license of the Software, or (b) repair or replacement of the Software, that does not meet this 
Limited Warranty and that is returned to Lantronix with proof of purchase. This Limited 
Warranty is void if failure of the Software has resulted from accident, abuse, misapplication, 
abnormal use or a virus. Any replacement Software will be warranted for the remainder of 
the original warranty period or thirty (30) days, whichever is longer.   
 
DISCLAIMER OF WARRANTIES. The Limited Warranty that appears above is the only 
express warranty made to you and is provided in lieu of any other express warranties (if any) 
created by any documentation or packaging.  LANTRONIX HEREBY DISCLAIMS ALL 
OTHER WARRANTIES, EXPRESS, IMPLIED OR STATUTORY, INCLUDING, BUT NOT 
LIMITED TO, THE IMPLIED WARRANTY OF MERCHANTABILITY, THE IMPLIED 
WARRANTY OF FITNESS FOR A PARTICULAR PURPOSE, AND WARRIANTIES OF 
NONINFRINGEMENT, TITLE, QUIET ENJOYMENT, AND QUIET POSSESSION.      
 
LIMITATION OF LIABILITY AND REMEDIES. IN NO EVENT SHALL LANTRONIX OR ITS 
SUPPLIERS BE LIABLE FOR ANY SPECIAL, INCIDENTAL, INDIRECT, OR 
CONSEQUENTIAL DAMAGES WHATSOEVER (INCLUDING DAMAGES FOR LOSS OF 
PROFITS OR CONFIDENTIAL OR OTHER INFORMATION, FOR BUSINESS 
INTERRUPTION, FOR PERSONAL INJURY, FOR LOSS OF PRIVACY, FOR FAILURE TO 
MEET ANY DUTY INCLUDING THAT OF GOOD FAITH OR OF REASONABLE CARE, 
FOR NEGLIGENCE, AND FOR ANY OTHER PECUNIARY OR OTHER LOSS 
WHATSOEVER) ARISING OUT OF OR IN ANY WAY RELATED TO THE USE OF OR 
INABILITY TO USE THE SOFTWARE, THE PROVISION OF OR FAILURE TO PROVIDE 
SUPPORT SERVICES, OR OTHERWISE, EVEN IN THE EVENT OF THE FAULT, TORT 
(INCLUDING NEGLIGENCE), STRICT LIABILITY, BREACH OF CONTRACT OR BREACH 
OF WARRANTY OF LANTRONIX OR ANY SUPPLIER, AND EVEN IF LANTRONIX OR 
ANY SUPPLIER HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. The 
entire liability of Lantronix and any of its suppliers under any provision of this Software and 
your exclusive remedy for all of the foregoing shall be limited to the greater of the amount 
actually paid by you for the Software license or U.S.$5.00.  
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THIS WARRANTY GIVES YOU SPECIFIC LEGAL RIGHTS, AND YOU MAY ALSO HAVE 
OTHER RIGHTS THAT VARY FROM JURISDICTION TO JURISDICTION. 
 
For details on the Lantronix warranty replacement policy, go to our web site at 
http://www.lantronix.com/support/warranty/index.html 
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